2011年04月27日

ドリトルその4

前回、課題1)で終わってしまったので続きをさせました。前回書き忘れましたが、これらの課題は以前ブログに書いたものを使っています。

ちなみに解答例は次のような形ですが、特に示しません。課題2)の簡略した形のみ見せました。

解答例−課題1)
かめた=タートル!作る。
かめた!100 歩く。
かめた!90 右回り。
かめた!100 歩く。
かめた!90 右回り。
かめた!100 歩く。
かめた!90 右回り。
かめた!100 歩く。
かめた!90 右回り。


解答例−課題2)
かめた=タートル!作る。
かめた!100 歩く 90 右回り。
かめた!100 歩く 90 右回り。
かめた!100 歩く 90 右回り。
かめた!100 歩く 90 右回り。

または、
かめた=タートル!作る。
かめた!100 歩く 90 右回り 100 歩く 90 右回り 100 歩く 90 右回り 100 歩く 90 右回り。


そして、「 」による繰り返しを用いて、
かめた=タートル!作る。
「かめた!100 歩く 90 右回り。」!4 繰り返す。


ここまで分かれば、3〜6は楽しんでできます。

解答例−課題3)
かめた=タートル!作る。
「かめた!100 歩く 120 右回り。」!3 繰り返す。


※外角なので三角形は120度回らなければいけませんね。

解答例−課題4)
かめた=タートル!作る。
「かめた!100 歩く 60 右回り。」!6 繰り返す。


解答例−課題5)
かめた=タートル!作る。
「かめた!100 歩く 72 右回り。」!5 繰り返す。


解答例−課題6)
かめた=タートル!作る。
「かめた!100 歩く 144 右回り。」!5 繰り返す。


※☆マークの真ん中が五角形しているところから角度を割り出します。

さて、課題7以降のための「命令一覧プリント・その2」を配りました。

図形オブジェクトの命令(一部)
「図形を作る」で作られた独立したオブジェクト。タートルオブジェクト同様、他の図形と一部が重なるというイベントが発生すると、「衝突」で定義したメソッドを実行する。また「動作」というメソッドを定義しておくと、ボタンのようにマウスで図形をクリックしたときに実行する。










命令用途使用例
図形を作る今まで描いていたものを独立させる図形1=かめた!図形を作る。
作る自分を複製して新しい図形を作る星2=星1!作る。
右回り右に回る星1!90 右回り。
左回り左に回る星1!90 左回り。
位置原点からの位置を指定して移動星1!100 100 位置。
塗る( )で括られた色に自分を塗る星1!(黄) 塗る。
拡大する自分をn倍する。または縦横にx倍y倍する星1!2 拡大する。
星1!2 3 拡大する。
消える画面から見えなくなる。星1!消える。
現れる消えていた姿を戻す。星1!現れる。
向き?現在の角度を右から右回りで調べるラベル!(星1!向き?) 作る。


色オブジェクトの命令(一部)
色を表すオブジェクト。よく使う8色として「黒、赤、緑、青、黄、紫、水色、白」が用意されている。それ以外はRGBを指定して「作る」で作る。

命令用途使用例
作るRGBの順に0〜255までを指定して色を作るピンク=色!255 136 255 作る。
星1!(ピンク) 塗る。
暗くする色を暗くする濃い緑=緑!暗くする。
明るくする色を明るくする。暗くした色を再び明るくする明るい緑=緑!明るくする。
半透明にする裏側が透けて見える色を作る透ける青=青!半透明にする。



課題7)は課題8)以降の序章。課題8−1)から課題8−9)まででペイントが完成する。ペアプログラミングの形を取り、二人ずつ、あーでもないこーでもないと悩みながら進めていく。グループによってはかなり苦労していましたが、一番進んだグループは課題の指示にない「☆を作るボタン」を作成していました。まさにサンプル通りです。もちろん、サンプルプログラムは見せていません。

ボタンの位置は各班バラバラですが、それでまったく構わないと思います。「使いやすいアプリケーションである」と思えるものであればいいのですから。

なぜそうしたのか、どのような苦労があったのか、それが明かであれば、次に繋がると思います。続きを読む
posted by n_shimizu at 23:59| Comment(0) | TrackBack(0) | 授業2011

2011年04月24日

ドリトルが文字化けをする

情報Bの授業でアルゴリズムやオブジェクト指向プログラミングを扱うために、ドリトルをがっぷり四つで取り組むことにしました。

ただ本校の環境では文字化けしてしまう現象に悩まされています。

以下はサンプルプログラムの「ペイント」を実行したものです。

ドリトル文字化け.gif

……酷いものです。なにがなにやらさっぱりわかりません。
最初は文字コードや言語設定がおかしいのかと思ったのですが、半角英字、つまり ASCIIコード部分ですら化けます。たとえば「GO」と表示しようとすると「FN」になるといった具合です。この場合コードが1ずつ小さくなっていますが、漢字となると法則性すらわかりません。

上記画像をもう一度ご覧頂くと一番下に「「ペイントソフト」(「ドリトルで学ぶプログラミング」Activity3)」という文字が読める!ということに気づきました。

ラベルは読めて、ボタンが化けるのか?とも思いましたがそうではなく、文字サイズであることが分かりました。

上記画像の左上、「あるく」だけは表示されています。「23 文字サイズ」を指定しているのです。ボタンのデフォルト値は文字サイズ24ポイントです。

いろいろ試すと、ラベルであってもボタンであってもフィールドであっても、本校パソコン室の環境では24ポイント以上のサイズにすると文字化けが発生すると言うことが分かりました。原因はドリトルではなく、環境にあることがハッキリしました。

さて、原因は何でしょう?フォントが壊れているのか、JAVAのインストールがうまくいってないのか、グラフィックドライバ等がおかしいのか、これから探っていきたいと思います。

※もしよければ旧ブログのドリトルの記事も参照下さい。
情報科雑感: ドリトル
posted by n_shimizu at 17:52| Comment(0) | TrackBack(0) | ドリトル

2011年04月23日

ドリトルその3

さて、ドリトルでいろいろ自分で考えて実習していくにあたり、命令について一覧となっているものが必要です。公式ページの命令一覧を見ろというのが一番正しいのですが、どこを見ていいのか初学者にはきつい。そこで小出しに命令一覧その1、その2という形でプリントを配ることにしました。お分かりの通り、「1時間で学ぶソフトウェアの仕組み」に出てくるオブジェクトの命令一覧になっています。

その1です。

タートルオブジェクトの命令(一部)
動き回るキャラクター。動くと軌跡が残るので図形を描ける。

命令用途使用例
作るオブジェクトを作るかめた=タートル!作る。
歩く前進するかめた!100 歩く。
右回り右に回るかめた!90 右回り。
左回り左に回るかめた!90 左回り。
変身するカメの画像を違うものにするかめた!”tulip.png” 変身する。
ペンなし軌跡を描かない(で移動する)かめた!ペンなし。
位置原点からの位置を指定して移動かめた!100 100 位置。
向き右からの角度で向きを指定するかめた!90 向き。
閉じる書き始めの点まで線を引くかめた!閉じる。
図形を作る軌跡の線を切り離して図形にするかめた!図形を作る。
線の色描く線の色を変えるかめた!(緑) 線の色。


ボタンオブジェクトの命令(一部)
画面に表示されるGUI部品の一つ。押されることを「動作」というメソッドで感知する。

命令用途使用例
作るオブジェクトを作る右ボタン=ボタン!”右” 作る。
読むボタン上の文字を読んで返すラベル!(ボタン1!読む)作る。
書くボタンに文字を書くボタン1!”あいうえお” 書く。
(:動作)押された時の動作を定義する右ボタン:動作=「かめた!3 右回り」。


タイマーオブジェクトの命令(一部)
一定時間毎に、「……」のブロックを繰り返して実行する。標準で0.1秒間隔100回。
命令用途使用例
作る新しいタイマーを作る時計=タイマー!作る。
間隔間隔を変更する時計!1 間隔。(1秒間隔にする)
回数回数を変更する時計!10 回数。
時間n秒間動くようにする時計!5 時間。
実行ブロックを実行する時計!「かめた 10 歩く」実行。
待つタイマーが終わるのを待つ※時計!待つ。

※(待つを実行しないと次の行の命令が同時に実行される)。


また課題プリントを渡しました。

課題0)宝拾いゲームの復習(もう一度入力して確かめる)。
課題1)一辺の大きさが100の正方形を描いてみよう。→「正方形1」で保存。
課題2)正方形をなるべく簡単な記述で描いてみよう。→「正方形2」で保存。
課題3)正三角形を描いてみよう。→「正三角形」で保存。
課題4)正六角形を描いてみよう。→「正六角形」で保存。
課題5)正五角形を描いてみよう。→「正五角形」で保存。
課題6)☆を描いてみよう。→「星」で保存。
課題7)図形を描いた後、「かめた!(色) 図形を作る。」で色を塗ってみよう。
課題8−1)「前進」と表示されたボタンをつくり、前に20歩進むようにしましょう。
課題8−2)「もどる」と表示されたボタンをつくり、後ろに20歩進むようにしましょう。
課題8−3)「左」と表示されたボタンをつくり、30度左に回転するようにしましょう。
課題8−4)「右」で右回転ボタンもつくりましょう。
課題8−5)ボタンを作る際に、『左ボタン=ボタン!“左” 作る −380 185 位置。』などと位置を指定して、ボタンが上手に配置されるようにしましょう。
課題8−6)「線なし」と表示されたボタンをつくり、線を描かないようにしましょう。
課題8−7)「線あり」で、再び線を描くようにしましょう。
課題8−8)「図形を作る」ボタンをつくり、このボタンの『:動作』として
『「:直前の図形=かめた!図形を作る」。』
を定義して、描いた線が図形オブジェクトになるようにしましょう。
課題8−9)「青」などのボタンを作り、このボタンの動作として、
『「:直前の図形!(青) 塗る」。』
などを定義して、図形に色を塗られるようにしましょう。色ボタンの大きさも調節しよう。


分かる人には分かると思いますが、課題8は1)〜9)まで完成させると、ほぼドリトル本のペイントと同じものができあがるはずなのです。

授業では課題1で終わり次回に続きました。
posted by n_shimizu at 23:59| Comment(0) | TrackBack(1) | 授業2011

2011年04月20日

【情報B】ドリトルの授業・その2?

今年は初めて「選択・情報B」を持つことになりました。

本校では一年生で情報Cを全員必修しています。
当初のアンケートによると情報系進学を考えてという生徒は皆無(^_^;

情報Bの内容をがっつり身につけさせるよりも教養的にやっていった方がいいようです。

しかし、やはり「情報」ですから、アプリケーション習得にしたくはありません。情報Bですから尚更です。

一つは「ゼミ形式」を取り入れること。

情報Cと重複する内容はすっ飛ばして、未習のところを2ページずつ順番に当て、生徒に授業をしてもらう形式です。時間は30分。

いきなり初回のテーマは「論理回路とプログラミング言語」。かなり手強いかなと思いつつ、ちゃんとオリジナルプリントを作り、AND回路、OR回路、NOT回路の説明と半加算器の説明などをしていました。時間は大幅に伸びて50分。まったく問題有りません。今後も期待できそうです。

さて、それと同時に、実習中心に私がやります。

「アルゴリズム」「データベース」「問題解決」の3つをじっくり取り組むことにしました。

とりあえず取り組みやすい「アルゴリズム」から。「アルゴリズムとは」ということを理論的にやるよりも、実習の中から順番に身につけるようにしていきたいと思いました。一昨年の情報Cでは全クラスに一度だけドリトルの「1時間で学ぶソフトウェアの仕組み」をまさに一時間だけやっています。

ということで、今回は「その2」です。題して「かっちりドリトル」。

1年生ではこちらから「これを入力しなさい」とリストを見せて、ひたすらそれを入力すると宝拾いゲームが完成しました。ソフトウェアとは何かということを「感じる」だけならそれでいいのですが、アルゴリズムなどを考えてコンピュータ上で表すためには文法等を押さえなければなりません。そこでスライドを使いながら下記のような解説をしました。

○ドリトルとは
・教育用プログラミング言語
・現在主流のオブジェクト指向
・・オブジェクト(もの、対象物)を中心に考える
・日本語文字を採用
・フリーソフト
・JAVA上で実行

○ドリトルの文法1
・基本オブジェクト
・・数値、文字列、ブロック、タイマー、他
・グラフィックオブジェクト
・・タートル、図形、パレット、他
・GUIオブジェクト
・・ボタン、フィールド、ラベル、 他
・音楽オブジェクト
・・メロディ、コード、ドラム、楽器
・その他

○ドリトルの文法2
・オブジェクトには特定の機能(メソッド)がある
・・例)タートルオブジェクト
・・・作る、歩く、戻る、右回り、左回り、移動する、位置、向き、ペンなし、ペンあり、閉じる、変身する、拡大する、線の色、線の太さ、衝突、他
・・例)タイマーオブジェクト
・・・作る、間隔、回数、時間、実行、待つ、中断
・無い機能は命令できない
・・歩け、進む、右周り、跳ねる……×

○ドリトルの文法2.5
・タートルオブジェクトとは
・・グラフィック関係のオブジェクトの一つ
・・移動する時に軌跡の線を残し、絵を描くことができる
・・描いた絵を切り離して図形にすることができる
・・規定値として
・・・原点(0,0)に現れる
・・・ペンあり
・・・亀の絵

○ドリトルの文法3
・オブジェクトに命令することで実行
・・オブジェクト!命令。
・・・例)タートル!作る。
・・「オブジェクトにメッセージを送信する」
・・オブジェクトをレシーバ(受信者)ともいう
・・「。」で動作が完結
・・半角と全角を区別しない
・パラメータは命令の前
・・例)かめた!10 歩く。

○ドリトルの文法4
・オブジェクトに名前を付ける(変数)
・名前を付けたものも新しいオブジェクト
・・かめた=タートル!作る。
・・かめた!10 歩く。
・・・※名前を付けないと二度と命令できない
・複数のオブジェクトを作る
・・かめた=タートル!作る。
・・かめた!100 歩く。
・・かめこ=タートル!作る。
・・かめこ!100 戻る。

○ドリトルの文法5
・同じオブジェクトは並べて命令できる
・・例)
・・・宝=タートル!作る。
・・・宝!“tulip.png” 変身する。
・・・宝!ペンなし。
・・・宝!100 100 位置。
・・次の表記と同じ
・・・タートル!作る "tulip.png“ 変身する ペンなし 100 100 位置。
posted by n_shimizu at 23:59| Comment(0) | TrackBack(0) | 授業2011

2011年02月20日

フォレストガンプは「アメリカ」

ずいぶん昔(1995年だそうで)の映画。

Yahoo!映画の評やall cinema online の映画評があまりにも浅薄なので、ここに「解説」を書こうと思います。

明るいアメリカの歴史の象徴「フォレスト・ガンプ」、暗いアメリカの歴史の象徴「ジェニー」の二人が織りなす物語。

知的障害に身体障害である「うすのろフォレスト(「ガンプ」とは「うすのろ」という意味。)」が最初と最後に出てくる鳥の羽のように「風に任せて」いたら本人の意思とは関係なく輝かしい成功をしてしまう。「成功」「勝利」が至上主義の「アメリカ」を皮肉っている。これは、現代アメリカを振り返ってみようという映画である。


話は「古き良きアメリカ」の60年代からはじまる。オールディーズのロックンロールの時代。

おじいさんのおじいさんのおじいさんの代からからアラバマ州に住んでいる生粋の「南部人」。つまり保守的で白人至上主義の地域。事実、母はKKKという白人至上主義団体の創立者「ネイサン・ベッドフォード・フォレスト」から息子の名前を付けている。この一事を持ってしても、この映画はただ者じゃないと覚悟をして見なければならない。

フォレストが足の装着具のせいで膝を曲げたままの姿勢のダンスをしていたことが、無名時代に自宅に宿泊したエルビスプレスリーの有名なダンスポーズの元になっているとしているところからフォレストの「成功物語」が始まる。

一方幼なじみジェニーは父親からの性的虐待の被害者。父親はすぐに逮捕されてしまう。最初から「暗部のアメリカ」なのである。

やがて足の装着具を外せるようになり、俊足になったフォレストはその足を活かしてフットボールの選手として知的障害を持ちながら大学進学という成功を果たす。

公民権運動の高まりの中、フォレストの南部の大学でもついに黒人の入学が決定。アラバマ州知事のジョージ・ウォレス知事は抗議の声明を発表(黒人を入学させることに!)。その場面の後ろでなぜかフォレストが写る。ちなみにフォレスト自身が人種差別的な思考はないことは入学する黒人が落とし物をしたときに拾ってあげていることで説明が付く。

大学でもフットボール選手として活躍、ケネディ大統領との対面も果たす。

ベトナム戦争が始まり「古き良きアメリカ」は終わりを告げる。フォレストは大学を卒業して軍隊に入る。そこで知り合うのは黒人のババ。ママも、ママのママも、ママのママのママもエビ料理をしてきた(黒人なので白人に仕えてきた)。ババはエビの漁師。エビのことなら何でも知っている(会話はすべて「エビ」。エビのことしか考えてないし、黒人であるババにはそれしか成功の道はない)。フォレストは軍隊の生活にも馴染んで認められる。

幼なじみのジェニーが歌手デビューしたと聞いて行ったのはストリップ劇場。彼女は裸をギターで隠しながら、場違いにフォークソングを歌って、観客にやじられる。歌っている曲は公民権運動を進める人々の間でテーマソングともいえるボブ・ディランの「風に吹かれて(この映画の隠れたテーマソング)」

やがてフォレストはベトナムへと派兵される。現地での小隊長はダンという人物。彼は南北戦争の時代から「名誉の戦死」を遂げてきた家系(とフォレストが言っている)。彼も「アメリカ」の一人。

敵の襲撃を受けたとき、ただ親友のババを救うために動いた結果、仲間を何人も救うことになりそのことで国家から表彰される。ダンは「名誉の戦死」を願っていたが、フォレストに助けられる。しかし両足を切断し「障害者」になってしまう。ジョンソン大統領から栄誉勲章を受ける。

帰り道、ベトナム反戦運動の集会でなぜかスピーチをすることになったがスピーカーが異常をきたしスピーチの内容はわからない。そばで聞いていたスタッフが涙する。おそらくアメリカにとって本当に大切なことをフォレストが語ったのであろう。

そこでヒッピーとなったジェニーに再会。ジェニーは反戦運動委員会の委員長と恋人同士になっている。しかし彼女に対する暴力をみて助けようとする。集会も運動も「理屈」ばかりが先走って本当に人間を大切にしていたのかという監督の意図が読み取れる。

1969年。アポロ11号が月面着陸に成功した頃、アメリカ−中国はピンポン外交により関係を深めて1972年の米中国交樹立へと向かう。この時もフォレストはピンポンでずば抜けた才能を発揮して名誉を高める。

ニクソン大統領にも対面して栄誉表彰を受ける。しかし、かの有名な「ウォーターゲート事件」発覚のきっかけをフォレストが作って、ニクソン大統領は辞任。このことからもフォレストが「成功のアメリカ」の象徴であっても「体制側」ではないとわかる。

ダン小隊長は障害者ゆえに浮浪者同然の生活になっている。これも弱肉強食のアメリカらしい。ダダとエビ漁の船を持つ夢を語ると、ダンから「おまえが船長になったら俺は宇宙飛行士になる」と言われる。

一方ジェニーはヒッピーの象徴であるドラッグで体も心もぼろぼろになって自殺をも考えるようになる。当時ヒッピーが自殺をしたり、ドラッグで中毒死するのはよくあることだった。

フォレストとダンの始めたエビ漁業が大当たりして、またしてもフォレストは成功する。そしてダンが創業当初のアップルコンピュータ(創業は1976年。創始者二人はヒッピー)に投資してくれたおかげでその後もフォレストは何不自由ない生活を送れるぐらいの大金持ちになる。

母がガンで亡くなった後にふらりとジェニーが現れ、一夜を共にした後、また去ってしまう。

落胆したフォレストは急に走りたくなり、アメリカを東西に何往復も走り始める。すると彼を「平和の使者」として慕った「信者」がぞろぞろと後を追って走るようになる。彼らの中から有名なステッカーやニコちゃんマークのTシャツの発案者が現れるがみんなフォレストの言葉や行為からだった。

3年間走り続け急に走るのを止めたフォレストにジェニーから連絡が入る。彼女には子供がいて、それは彼の子供だった。

そしてジェニーと結婚する。結婚式で現れたダンは宇宙船を造るチタン製の義足で歩けるようになり、アジアン系の女性と婚約。

しかし、ジェニーは病気で死ぬ。母を看取った同じベッドで。ロナルド・レーガン大統領時代なので、その頃の病としてはエイズなのだろう。

フォレストはジェニーの墓前でつぶやく。

「ジェニー。僕には分からない。正しいのはママなのか、ダン小隊長だったのか、僕らには皆運命があるのか それとも風に乗って、ただ さまよっているのか たぶん、その両方だろう 両方が同時に起こってる」

というセリフ。

ママのアメリカ、ダン小隊長のアメリカ、ジェニーのアメリカ、フォレストのアメリカ。どのアメリカが正しいのかはわからない。「その答えは、風に吹かれている」(「風に吹かれて」の歌詞の一部)すべてが同時に起こっているんだ。
posted by n_shimizu at 23:17| Comment(8) | TrackBack(0) | 日記

2010年07月20日

表現の自由について

日本のメディアは表現の自由守れるか(1/3):オピニオン:青山学院スタイル2010 : YOMIURI ONLINE(読売新聞)
http://www.yomiuri.co.jp/adv/agu2010/opinion/vol1/


この方の主張を自分勝手に解釈すると、

メディアの表現の自由には、成熟した「個」としての民衆が必要である
表現の自由は脆(もろ)いものである

ということでしょうか。


我々教員は、日々クリエイティブなことに挑戦していると自負しています。新しい学説やネタを常に仕入れて、それを生徒に還元しよう、新たなメソッドを追求していこうという姿勢が欠かせません。これは公立であれば教員は公務員な訳ですが、通常の公務員の世界から見ると異質でしょう。

ブログという表現はこのクリエイティブな側面を世に問うことでみずからを磨いていくことだと思っています。単なる自己満足ではないのです。一人一人が新たな「道」を開拓し、それを参考にして他の方が続くための、現代らしい手段と言えます。特に「情報科」という教科の性格上、情報機器やインターネットと親和性が高く、また学説やメソッドが確立した教科とは言えない中でのパイオニアとしての性質が、意識のあるメンバーにとってはまたとない発表の機会であると言えます。

しかし、一方で公立学校に所属するからには、所属する組織、都道府県や市区町村を背負っている立場であることも事実です。

とある、かなり活発に情報発信をしていた情報科の方が、最近ひっそりとブログを閉じました。それはかなり的外れな苦情、というか「いちゃもん」を親組織に投げ続けられた結果です。クレーマーと言っても良いでしょう。

残念ながら、そこの組織は、彼を守る方向には行きませんでした。事勿れの官僚的な対応により、閉じることになりました。もちろんクレーマーによる彼の精神的打撃も無視できない影響がありましたが。

「間違いがあってはいけない」という無謬主義がはびこると、個人の活動を極端に制限する方向に進みます。しかし、まったく間違えを起こす可能性のないクリエイティブな活動などあり得ません。もちろん気をつけなければいけませんが、クレームを付けたがる人というのは世の中に一定数いるわけで、それは毅然として「間違っていません」と言えばいい話です。それを言われるのが嫌だからという理由で表現を制限する、それは憲法に保障された基本的人権を制限していることになぜ気がつかないのでしょうか。

表現の自由は、信教の自由と並んで、ともすれば簡単に侵されてしまう心の自由です。だから「憲法」に書いているのです。それを可能な限り保障するのが「大人の社会」と言えるのではないでしょうか。そこに「もしかしたら危ないから」という予防で制限を掛けるのは、幼稚園児に「そっちへ行ったら危ないよ」と言って縄を張るのに等しいと言えます。

そして、憲法で保障された自由よりも組織を守ることを優先させるとすれば、それは江戸時代の徳川幕府の「農民は生かさぬよう殺さぬよう」「知らしむべからず依らしむべし」等と同様の守りの姿勢であると言えましょう。

私もかなり気をつけて記事を書いています。特に生徒の個人情報に関わるような事の無いように(この「個人情報」についてもかなり拡大解釈されていますね)。

しかしクレームを付ける人はどんなものにも付けるものです。その時、組織は守りに入るのか、正すべき事は正して闘うのか。それがその組織の正当性を公に問いながら発展していくための鍵と言えるでしょう。
posted by n_shimizu at 02:29 | TrackBack(0) | 日記

2010年07月19日

追悼・梅棹忠夫先生

文化人類学者、生態学者、民族学者、日本語のローマ字論者(ローマ字化推進論者)で、社団法人日本ローマ字会会長、エスペラント運動家(エスペランティスト)、世界エスペラント協会の名誉委員……などなど、肩書きはたくさんある。

わたし的には「知的生産の技術」の著者、これに尽きる。というか、それ以外の活動についてあまり知らない。この本自体、ローマ字化推進の萌芽が見て取れる内容だが、それについては機会があったらいずれまた。


1969年、すなわち、私が生まれた年に発刊されたこの「知的生産の技術」。高校1年生の時に(たしか)現代社会の授業で推薦されて読んだ。

その時の衝撃と言ったら、自分の人生の中でのターニングポイントであったといえるぐらいの出来事だった。

現代風に言えば(情報科の立場から言えば)、


  • 記録とはデータである

  • それは規格化をして(フォーマットを整え)

  • 正規化(的な)ことをして初めて意味がある



ということを、生まれて初めて教えてくれたものだった。

私が、電子工作をしたり、プログラミングを始めたのは小学生の頃。まぁその分野としては少し早熟気味だったかもしれない。しかし、この時は、ただ単に「コンピュータ」を学んだに過ぎない。

しかし、この本を読み、「情報」の取り扱い方を学んだ。ノート一つ取る際にも、未来の自分という他人に向かってのメッセージとして、記録しなければならないことを知った。

時は過ぎ、高校教師になった。理科の教員として。相変わらずパソコンをいじるのは好きだった。そんな中で、新しく「情報」という教科が生まれることを知り、自分が本当にやりたいことは「理科」ではなく「情報」だったのではないかと気づき、喜び勇んで免許取得の講習会を受けた。

講習会は多岐にわたった。それは専門教科「情報」の免許も一緒に取ることになったから。それはまだいい。「情報」が余りに「コンピュータ」に偏っている気がした。

質問をした。

「情報科」とは「情報」なんですか、「コンピュータ」なんですか。


答えは曖昧だったが、「どちらかというとコンピュータ」というイメージを受けた。

講習を受けた帰り道、お茶の水で買った書物が、脳内ネットワークを論じたものと、当時そろそろ実用的に使われ始めた Web の HTML の元になっている SGML の解説書(おそらく大学の教科書)だった。しかし、どちらも難しくて読了できなかった。

今思うと、認知心理学などを学びたかったのだろう。コンピュータに入る前に、人間の頭の中でどう認識されているのかを知る必要がある、そして、Webを始めとする人間の知の繋がりの仕組みや理論を知りたい、そういう思いだった。当時はそういった学問の存在がわからなかった。

情報科の教員として生徒に教え始めた。あまりに幅のある生徒にたじろいだこと、TTで一緒に組む先生の認識に合わせる必要があったことから、「情報」の授業は「パソコン教室」になった。違う違うと思いながら。

情報科の教員になって5年目の時。学校も移り、TTをする相手も変わり、その相手から、「知的生産の技術」の話になった。この本に「情報科」が出来ることが予言されているよ、と。

驚いた。本当に驚いた。慌てて本書をめくると後書きに次のようにある。

『ここにあげたさまざまな知的生産技術の教育は、おこなわれるとしたら、どういう教科でおこなわれるのであろうか。国語科の範囲ではあるまい。社会科でもなく、もちろん家庭科でもない。わたしは、やがては「情報科」というような科目をつくって、総合的・集中的な教育をほどこすようになるのでないかとかんがえている。』

なんと、意識していなかった、自分のアイデンティティがここにあったのだ。

そう、パソコンのことを教えたかったのではなく、「人間の中身」を教えたかった。自分は何を見て・聞いて、それをどう感じるのか。それをどう咀嚼するのか。そしてそれをどう他人に伝えるのか。つまり、情報の収集・編集・加工・発信という、まさに情報活用能力+認知心理学、それがあってはじめて、コンピュータなどのを使う上での「情報学」が生きてくる。それを教えたかったのだ。

子供の頃のコンピュータ好き、高校生の頃に本書から受けた衝撃、それが熟して「情報科教員」という今に至っていたのだ。

この「知的生産の技術」は、私にとって今の自分がある特別な一書なのである。

先日お亡くなりになった著者の梅棹忠夫先生には謹んで哀悼の意を表したい。そして、尽くせぬ感謝を送りたい。
posted by n_shimizu at 02:42| Comment(0) | TrackBack(1) | 日記

2010年07月18日

都高情研本年度第1回の研究協議会に参加

こちらの研修会・研究協議会ですね。こちらに参加しました。

場所はK高校。初めて行くところです。調べてみると本校からほぼ真北にバス一本で行けるのですね。ということで、短縮授業を終え、他の仕事も終えた後で出発しても間に合いました。

北の門から入ると、
100716_1442191.jpg


林!
100716_1442461.jpg

ええっ?!学校内に林があるなんて!

すぐにひらけて普通に校舎が見えました。
100716_1443511.jpg

傾斜を利用しているので入り口の校舎と奥の校舎は2Fと1Fが横に繋がっている構造になっていまして、校内で迷いました。

とても広い、のどかな学校です。

さて会場についてはそれぐらいにして内容はというと。

講師は私立高校で情報を教えているI氏。とてもまじめに勉強されています。都高情研の研究大会でも発表され(自分は自分の発表があり聞けなかった)、とても評判が良く。ぜひとも聞いてみたかった。

濃い。とても濃い。テーマは「普通教科「情報」における著作権に関する授業実践」なんですが。5時間かけて行われているとのこと。すごい。

なかでも、「著作権は人工的な権利である」こと。「現実に合わせて後追いで法律が整備されていること」などは自分の中ですとんと落ちました。自然法とはずいぶん違うわけでして、「だから法律そのものから学ぶ」というのはその通りですね。映画だけは特別扱いされているという疑問は感じていたのですが、「映画は莫大な投資をされているので、製作会社が著作権をもっているのが、投資に対する利益の回収をしやすいから」という、これも現実に合わせた権利であることですとんと。

著作者の権利を守る著作権がある。そしてそれを侵害していることがある。でも「侵害=悪」かというと必ずしもそうではなく、むしろ「タダで宣伝してもらった」という利益にもなる。そこに「親告罪」であることが生きてくる。なるほど。

多くの生の事例を出して、生徒にぶつける内容はすごいとしか言いようがない。

著作権は、グレーの部分が多く、事例をたくさん勉強しないとおいそれと語ることが躊躇される。それはやはり「人工的な権利」であり、もっというと「大人の事情」によって、それが「悪」になったり「善」になったりする部分。

でもそれは、情報科らしい、「トレードオフ」の関係なんだよ、考えなければならないんだよ、という結論に持って行く。

情報社会を語るとき、情報が価値を持っている社会であると、またその「価値」とは基本的に「お金」であると、よく言う。そういう観点から考えると、著作権は情報社会を経済的に成り立たせる法的基盤と言える。今考えるととても当たり前なことに気づかなかった自分が恥ずかしい。

年間の授業の中でこれだけ厚みのある内容を取り入れられるのかは、それぞれの事情によるだろう。教科「情報」で扱う内容は、どれをとってもゆうに4,5時間もってしまうテーマばかり。それのどこを膨らませるかは担当者に任されているといえる。ただ、1学期で1時間で終わらせた内容だったが、もう一度きちんと取り上げた方がいいと思った。

パクらせてもらうだけでなく、自分も参考文献に上げて頂いた(わざわざキャリーバッグにたくさん入れてもってきて頂いた)ものを勉強して、生徒にぶつけていきたい。

刺激をいただいた研修だった。
posted by n_shimizu at 03:06| Comment(0) | TrackBack(0) | 日記

2010年05月18日

「CPUの創りかた」を読む。感動した!面白すぎる!



2003年の本なんですよね。前から気になってはいたんですが表紙が萌え絵なのが引いてしまっていました。先日、大井町LABI の本屋さんで見つけてしまったので即ゲット。読んでみたら、いやあ面白い。今まで読まなくてホントに損したと思いました。

30日でできる! OS自作入門

と並んでいい出来です。

一度読み終わっただけでは飽きたらず、二度目も読みました。
続きを読む
posted by n_shimizu at 21:28| Comment(0) | TrackBack(0) | 日記

2010年04月04日

H21年度都高情研研究大会に参加&ポスター発表

平成21年度東京都高等学校情報教育研究会 研究大会に参加しました。他の方のブログ記事はこちらを。

色の3原色・光の3原色(都高情研・研究大会) - 情報科blog
東京都高等学校情報教育研究会に参加: WeekEnd 情報科
東京都高等学校情報教育研究会 研究大会: 総合学科「情報」日誌(私の姿が写真に(笑))
都高情研 研究大会 - 情報科授業研究
ネットで教科「情報」日記 : 2009年度 都高情研 研究大会

そして今回、自分としては初の「ポスターセッション」の発表。

内容は、「31回目インターネットのしくみ(紙パケット)」。

実のところ、最初の東大の先生の講演と、研究発表最後の田崎さんの発表以外はほとんど聞けず。

模造紙一枚で収めるぞ!と模造紙を用意したものの、A4の紙が何枚貼れるかよくわからず、学校ではいろいろ重なり超多忙な日々。とりあえず60部用意せよというハンズアウト分の印刷のみで家に帰っての準備となりました。

しかし、土日の用意は自然と子供たちが寝てからという制約があり、結局日曜日の夜中。配置を考えていたら、意外と狭いことがわかり、結果として「ポスター」としてはほぼ図のみ。後は資料を読んでね、という形になりました。まぁそれはそれでいいのですが。

作ってみたら、資料にもこの図は入れておいたほうがいいなぁとなりそれも60部印刷。結局用意が終わったのが午前4時頃となってしまいました。

さて、実際のポスターの方ですが、ポスターの時間はもちろん、それ以外にも聞きに来てくれる方が多く、いくつかのブログにもお褒めの言葉をいただきました。別に shimizu のオリジナルというわけではなく、様々な方の実践を参考にしてできあがった物なので申し訳ない気持ちもありますが、色々な学校で実践できるパッケージ化できたのかな、ということで、発表した甲斐があったと思いました。内容は紀要の方にも載せていただく予定です。

やはり人間同士の交流・意見交換ができるのがいいところ。懇親会も含めてとても有意義な一日でした。
posted by n_shimizu at 22:51| 日記